fbpx
Función SI en Excel 【 EJEMPLOS/ SINTAXIS/ ARGUMENTOS 】
La mejor función NUMEROALETRAX 【 COMPLEMENTO 】
marzo 13, 2020
Función SI en Excel 【 EJEMPLOS/ SINTAXIS/ ARGUMENTOS 】
Función PORCENTAJE en Excel 【 EJEMPLOS 】
mayo 1, 2020

Función SI en Excel

Bienvenido/a a un nuevo tutorial de fórmulas en Excel, en esta ocasión toca aprender a utilizar la función SI, o también conocida como IF para la versión en ingles. Si no la conoces te recomiendo llegar hasta el final para que conozcas todos sus trucos.

La función SI es una herramienta muy solicitada entre los usuarios en Excel, ya que nos ayuda escribir resultados dinámicos en una celda dependiendo de una condición.

Para que sirve la fórmula SI

Está fórmula en muy útil cuando necesitamos establecer un valor en una celda, según uno o varios criterios.

Personalmente me gusta llamarla como función que da inteligencia a Excel ya que nos permite tomar decisiones en una celda bajo nuestras consideraciones.

Así que gracias a la fórmula SI podremos, por ejemplo, si un cliente es categorizado como nuevo si su fecha de registro pertenece al mes actual.

  =SI(MES(E9)=MES(HOY()),”Cliente Nuevo”,”Cliente Anterior”)  

Función SI en Inglés

Si lo que necesitas es utilizar la fórmula SI en la versión de Excel en Inglés, deberás utilizar la función equivalente:

IF

La fórmula IF funciona exactamente igual a SI, los parámetros son los mismos y se colocan en el mismo sitio.

Sintaxis de la función SI en Excel

Está formula utiliza 3 parámetros, de los cuales solo 1 es obligatorio, en ellos se solicita una prueba de decisión, una respuesta positiva y una respuesta negativa a la prueba. Ahora encontrarás cada uno explicado a detalle.

Función SI en Excel 【 EJEMPLOS/ SINTAXIS/ ARGUMENTOS 】

ARGUMENTO 1. PRUEBA LÓGICA.

Es único parámetro obligatorio y por lo tanto el más importante. Se compone de una condición que evaluará el tipo de resultado de salida y utiliza OPERADORES LÓGICOS para trabajar.

OPERADORES LÓGICOS

Consisten en una serie de caracteres especiales que nos ayudarán a comparar valores numéricos, textos, fechas o de formula, que tienen como característica primordial que su resultado es un valor binario, es decir Verdadero o Falso.

Es probable que más de uno te resulte familiar

TABLA OPERADORES LÓGICOS

Función SI en Excel 【 EJEMPLOS/ SINTAXIS/ ARGUMENTOS 】

Entonces por ejemplo si requerimos saber si una celda A1 es mayor a 100, la condición lógica seria:

   A1>100   

O si necesito saber si hoy es viernes, preguntáramos así:

  DIASEM(HOY) = 6  

*Nota. La semana inicia en Domingo que es igual a 1.

Ahora que ya ha quedado claro como trabajan las pruebas lógicas dentro de la fórmula SI, continuemos con el resto de los parámetros.

PARÁMETRO 2. VALOR VERDADERO.

Segundo parámetro de la función SI, el cual es opcional. En este parámetro podremos colocar el valor de respuesta afirmativa, es decir, lo que deseamos colocar en caso de que la condición lógica se cumpla.

En caso de omitir este parámetro, Excel indicara VERDADERO.

Los tipos de respuesta que podremos utilizar son TEXTO, NUMERO, FECHA, UNA CELDA o OTRA FORMULA. Para las respuestas tipo texto, recuerda que debes incluir el resultado entre comillas “x”

Revisemos el siguiente ejercicio: Indicar si el nivel de almacén requiere reordenar material o si está estable. Considera que el nivel de porcentaje de cada producto inicia en la celda B1.

La fórmula para resolver este ejercicio quedaría como:

  =SI(B1<1,”REORDENAR”)   

*Nota. Para valores en porcentaje te recomiendo usar decimales, 1 es igual a 100%.

Si el resultado debería ser el número 5, entonces nos quedaría:

  =SI(B1<1,5)   

*Nota. Cómo este resultado es tipo numérico, no requiere comillas.

ARGUMENTO 3. VALOR FALSO.

Tercer y último parámetro de la función SI, al igual que el anterior, es opcional y la única diferencia es que este parámetro representa la respuesta negativa a la condición evaluada.

En caso de omitir este parámetro, Excel indicara FALSO.

Entonces si la condición no se cumple, este parámetro nos servirá para establecer la respuesta a ello.

Continuando con el ejerció del inventario, la fórmula completa quedaría como:

  =SI(B1<1,”REORDENAR”,”OK”)   

De esta manera si el nivel es superior o igual al 100%, la celda indicara OK.

Función SI en Excel 【 EJEMPLOS/ SINTAXIS/ ARGUMENTOS 】

TODAAAAS LAS DUDAS, las resolvemos en los comentarios ?.

Profile
Gerardo Castro
Ing. Programador VBA y .NET
Me encanta programar en Excel y buscar nuevas formas de hacer las tareas más rápido.

¿Tienes alguna pregunta? Venga contestamos todas 😎